Unable to approve jobs
Resolved·Degraded performance

The issue is now resolved.

Wed, Jan 7, 2026, 08:25 PM
(1 week ago)
·
Affected components
Mobile app
Updates

Resolved

The issue is now resolved.

Wed, Jan 7, 2026, 08:25 PM

Monitoring

The fix is rolling out now. We'll test and monitor to confirm the issue is fully resolved.

Wed, Jan 7, 2026, 08:07 PM(18 minutes earlier)

Identified

We are rolling out a fix now.

Wed, Jan 7, 2026, 08:02 PM

Investigating

Users are currently unable to approve jobs. We are investigating the cause.

Wed, Jan 7, 2026, 06:53 PM(1 hour earlier)